Error when use simple_switch

An error occurs when loading instructions to simple_switch,specifically these two instructions:'port_add r1-eth1 1 ;port_add r1-eth2 2.I don’t know why. Any help is appreciated.
Error message:
RuntimeCmd: Invalid device manager operation (ERROR)
RuntimeCmd: Invalid device manager operation (ERROR)


Please upload anything that you ask about to your Github account such as P4 programs, P4Runtime rules, etc. I cannot help if I cannot see what you did and which rules you have used (exactly). Sometimes it is handy to upload all your stuff in one go (like the whole tutotial folder) to Github.

EDIT: If anyone else feels lucky please help to this person :slight_smile:


Thank you for your reply. Actually, I want to reproduce this project . This issue occurred when I ran the script. I wonder if the information I have added is enough.Please bear with me if my question is very stupid, I am a novice

Oh do not worry, back in time everyone one was a novice. We help you here, do not worry :slight_smile:

Is that link yours or do you have your own link?


No, this is not my own link. I read an article and I tried to reproduce the content of the article and this link was given in the article.I just loaded the content of the link into my own P4 environment .

I took a very fast look. This seems to be targeting the old P4_14 code, even if the compiler still supported some P4_16 features. This might not be the best approach at this point because a lot of the required tools have changed (requirements, python2.7, etc.).

Are you using the P4 VM they provide? Else it might be difficult to build your own VM from scratch.


Is this the case? Okay, then I will check the relevant environment again, because I did not use their VM thank you for your reply.